ユーザーの CSV 一括アップロードに関するトラブルシューティング | Adobe Admin Console

エンタープライズ版およびグループ版に適用されます。

概要

ユーザーページの「ユーザーを一括追加」機能では、管理者が CSV ファイルを使って Admin console に複数のユーザーアカウントを作成することができます。ユーザーアカウント作成処理のステータスと進捗状況は、一括操作の結果ページに表示されます。ユーザーアカウント作成処理は、いつでもキャンセルすることができます。

注意:

この記事で説明する手順で使用される CSV ファイルでは、区切り記号としてコンマ (,) またはセミコロン (;) が使用される場合があります。

Admin Console でユーザーを管理する方法について詳しくは、「ユーザーの管理」を参照してください。

ファイルの要件

ファイルをアップロードする前に、管理者が満たすべき処理要件を以下に示します。

  • ファイル形式とヘッダー
  • ファイルのデータまたは行に関する要件

ファイル形式とヘッダー

  • ファイルは、コンマ区切り値またはセミコロン区切り値形式で、拡張子は .csv です。各レコードは改行(CRLF)で区切られた 1 行にです。例えば、aaa,bbb,ccc CRLF のように記述します。詳しくは、RFC4180(CSV ファイル仕様)を参照してください。
  • 列ヘッダーは有効です。ヘッダー行は必須です。必須または任意のフィールドやファイル形式について詳しくは、「ユーザーの管理」にある CSV ファイル形式の表を参照してください。

回避策

警告:

以下の変更は、他のアプリケーションや表計算ソフトにも影響を与える可能性があります。したがって、CSV に必要な変更を加えた後、設定を元に戻してください。 

Windows 10

  1. Windows の「設定」に移動します。

  2. 時刻と言語地域と言語日付、時刻、地域の追加設定日付、時刻、数値形式の変更に移動します。

  3. 形式」ドロップダウンリストで、「英語(英国)」を選択します。

Windows 7

  1. コントロールパネルで、すべてのコントロールパネルアイテム地域と言語に移動します。

  2. 形式」ドロップダウンリストで、「英語(英国)」を選択します。

データまたは行に関する要件

各データ行について、以下の要件が満たされていることを確認してください。

  • 有効なメールアドレスで構成されている。
  • 製品のプロファイルや構成が有効である(存在する場合)。
注意:

グループ版をご利用の場合は、製品構成列のタイトルをグループ版製品に変更してください。また、この列のデータには、製品名(製品プロファイル名ではなく)を入力します。

  • オプションが有効である(存在する場合)。
注意:

国コードは、2 文字の ISO 3166 alpha-2)コードを使用する必要があります。

ファイルサイズの要件

CSV ファイルの行数は最大 25,000 行(最適なパフォーマンスを得るためには 5,000 行)です。ファイルが 5000 行を超える場合、Admin Console でファイルを処理する際にパフォーマンスの問題が発生します(次のセクション「ファイルの処理」を参照)。ただし、25,000 行を超える CSV ファイルは拒否されます。

25,000 以上のユーザーをアップロードする必要がある場合は、以下のいずれかをお勧めします。

  1. CSV を最大 25,000 行の複数のファイルに分割する。最適なパフォーマンスを得るには、5,000 行以下を使用してください。
  2. アドビのユーザー同期ツールを使用する。ユーザー同期ツールは、ユーザーとグループの情報を組織のエンタープライズディレクトリシステム(Active Directory やその他の LDAP システムなど)から Adobe Admin Console 内の組織のディレクトリに移すための、コマンドラインツールです。
  3. アドビの User Management REST API を使用する。この API は、組織の管理アプリケーションやプロセスと連携できます。
  4. Microsoft Azure または Google Google フェデレーションを使用して Admin Console で Federated ID を設定した場合は、それらの Admin Console コネクタを使用します。「Adobe との SSO 用に Google フェデレーションを設定する」または「zure AD Connector による SSO の設定」を参照してください。
  5. 上記のいずれの方法を使用してもユーザーを一括アップロードできない場合は、Admin Console にログインし、「サポート」にナビゲートして、アドビカスタマーケアに連絡してください。

ファイル処理

ファイルを処理する際、特定のドメインに基づいて、次の表に示すように各エントリが個別に処理されます。

すべての処理が完了すると、開始した管理者に概要がメール送信されます。読み込み操作をキャンセルすると、処理が停止します。ただし、既に処理済みの行はロールバックされません。

※1新規Adobe IDの場合ウェルカムメール内のリンクをクリックすることでパスワードを設定することができます。

※ 2 製品プロファイルが正しく割り当てられていない場合にはメールは通知されません。

※3アカウントが既に存在する場合は、製品プロファイルに追加します。

すべてのCSVのアップロードが完了すると、実行した管理者に電子メールで概要が送信されます。

インポート操作がキャンセルされた場合、処理は停止します。ただし、既に処理された行はロールバックされません。

ID の種別

アクション(追加処理順)

除外(以下に該当する場合は処理が完了されない可能性があります)

Federated ID

1. 指定された ユーザー名 でユーザーレコードが作成されます。

2. アカウント は指定された製品プロファイルに追加されます。

3. ドメインの決定以外、電子メールアドレスは使用されません。

4. 製品プロファイルの通知メールが有効の場合、ユーザーに製品利用開始の通知が送信されます。

  • ユーザー名 が既に存在する場合。
  • アドビシステムズ社が事業を展開する国ではない国コードの場合。
  • 製品プロファイルが無効であるか、ライセンスの割り当て数が超過している場合。

Enterprise ID

1. アカウントは、指定されたメールアドレスを使用して作成されます。

2. アカウント は、指定された製品構成に追加されます。

3. 製品利用開始の通知メール(ウェルカムメール)がユーザーに送信されます。

※2

  • Admin Consoleへのユーザーの追加処理中であるか、または指定した電子メールのアカウントが登録済みの場合。
  • アドビシステムズ社が事業を展開する国ではない国コードの場合。
  • 製品プロファイルが無効であるか、ライセンスの割り当て数が超過している場合。

Adobe ID

ユーザーの電子メールアドレスに製品利用開始の通知メール(ウェルカムメール)を送信します。

※1

※2

※3

  • Admin Consoleへのユーザーの追加処理中であるか、または指定した電子メールのアカウントが登録済みの場合。
  • アドビシステムズ社が事業を展開する国ではない国コードの場合。
  • 製品プロファイルが無効であるか、ライセンスの割り当て数が超過している場合。

ID タイプ

アクション

例外

Federated ID

  • 指定されたユーザー名でユーザーレコードが作成されます。
  • 指定した製品プロファイルにアカウントが追加されます。
  • メールアドレスは、ドメインを決定する以外には使用されません。
  • 製品プロファイルの通知設定が有効な場合、ユーザーにメールが送信されます。

  • ユーザー名が存在します
  • 国(存在する場合)がアドビのビジネスに開放されていません*
  • 組織または契約の種類に応じて、指定された製品プロファイルで十分な数のライセンスが利用できない場合、以下のいずれかが発生します。
    • チーム:「ライセンスが不足しています」というエラーが発生します
    • VIP:指定された製品プロファイルにアカウントが追加されますただし、ライセンスクォータを超えているため、ユーザーは製品を利用できません。
    • ETLA:指定された製品プロファイルにアカウントが追加されますユーザーは指定された製品にアクセスできます。更新時に調整分として請求されます

Enterprise ID

  • 指定されたメールアドレスでアカウントが作成されます。
  • 指定した製品構成にアカウントが追加されます。
  • ユーザーに案内メールが送信されます。

  • 既に招待状が処理中であるか、指定したメールアドレスのアカウントが存在します
  • 国(存在する場合)がアドビのビジネスに開放されていません*
  • 組織または契約の種類に応じて、指定された製品プロファイルで十分な数のライセンスが利用できない場合、以下のいずれかが発生します。
    • チーム:「ライセンスが不足しています」というエラーが発生します
    • VIP:指定された製品プロファイルにアカウントが追加されますただし、ライセンスクォータを超えているため、ユーザーは製品を利用できません。
    • ETLA:指定された製品プロファイルにアカウントが追加されますユーザーは指定された製品にアクセスできます。更新時に調整分として請求されます

Adobe ID

  • 指定されたメールアドレスでアカウントが作成されます。
  • 指定した製品構成にアカウントが追加されます。
  • 製品プロファイルを編集」で「メールでユーザーに通知」オプションを有効にした場合、ウェルカムメールがユーザーに送信されます。

 

  • 既に招待状が処理中であるか、指定したメールアドレスのアカウントが存在します.
  • 国(存在する場合)がアドビのビジネスに開放されていません*
  • 組織または契約の種類に応じて、指定された製品プロファイルで十分な数のライセンスが利用できない場合、以下のいずれかが発生します。
    • チーム:「ライセンスが不足しています」というエラーが発生します
    • VIP:指定された製品プロファイルにアカウントが追加されますただし、ライセンスクォータを超えているため、ユーザーは製品を利用できません。
    • ETLA:指定された製品プロファイルにアカウントが追加されますユーザーは指定された製品にアクセスできます。更新時に調整分として請求されます

 

警告 :

アドビのサービスおよびソフトウェアは、米国の輸出法によって管理されており、キューバ、イラン、北朝鮮、スーダン、シリア、ウクライナのクリミア地域を含む(ただしこれらに限定されない)、特定の地域におけるアドビのサービスおよびソフトウェアの輸出および使用が制限されています。

注意:

ユーザーの読み込み機能では、コンマ(,)またはセミコロン(;)などの特殊文字を持つユーザーニックネームをサポートしていません。

パフォーマンスの詳細

過負荷を避けるため、66.6%のデューティサイクルルールが処理の一部になっています。エントリーの処理時間がローリングアベレージと 10%以上異なる場合は、リクエスト処理が実時間の 2/3 しか消費しないようにスロットルが調整されます。

さらに、運用チームが管理するスロットル制御でも処理速度が制限される。スロットリング制御が明示的に設定されている場合、デューティーサイクル制御は無効になります。デューティサイクルベースのスロットリングに戻すための API 呼び出しがあります。

パフォーマンスに関するフィードバックを提供するために、1 秒あたりの処理リクエストの数が表示されます。

2 つの製品構成にそれぞれ追加された 1000 個のアカウントを作成するための目標速度は、66.6%のデューティーサイクルを考慮せずに 1 アカウント/秒であるため、見かけ上の処理速度は 0.66 アカウント/秒、約 40 アカウント/分となります。この速度で 1000 アカウントを作成するには、25 分かかります。この速度で 5000 アカウントを作成するには、2 時間 5 分かかります。

トラブルシューティング

この「トラブルシューティング」セクションでは、Adobe Admin Console での一括読み込み機能の使用時に発生しうるエラー状態やその他の問題のトラブルシューティングについて説明します。

アップロードエラー

特定の条件が充足されていない場合、ファイルのアップロードに失敗することがあります。

以下のような場合にエラーメッセージが表示されます。

  • ファイルが CSV 形式ではありません。
  • 必要な列ヘッダー(例:Email)が無効か存在しません。
  • 必須の列がありません。

次の手順を実行します。

  • .csv ファイル形式のみを使用します。
  • 列のヘッダーが有効であることを確認します。
  • 列の値が有効であることを確認します。

必須または任意のフィールドやファイル形式について詳しくは、「ユーザーの管理」にある CSV ファイル形式の表を参照してください。

CSV ファイル内のデータのフォーマットに関する問題を修正します。

  1. Microsoft Excel で CSV ファイルを開きます。

  2. シート内のデータを含む任意の列を選択(ハイライト)します。

  3. データ」タブを開き、「列にテキスト」をクリックする。

  4. 表示されるダイアログボックスで、「次へ」ボタンが無効になり、「完了」ボタンが有効になるまで「次へ」をクリックし続けます。

  5. 「完了」をクリックして、ファイルを保存して閉じます。

  6. 更新した CSV ファイルを Admin Console にアップロードします。

エラーメッセージは以下の状態で表示されます。

  • 必要な列のヘッダー(例:Email)は存在するが、対応する行の値がない場合:

各行に対応する値を入力してください。

処理エラー

処理エラーは、システムがアップロードされたファイルのデータ行を処理できない場合に発生します。詳しくは、「一括操作の結果を参照してください。

原因

INTERNAL_SERVER_ERROR エラーは、ゲートウェイのタイムアウトが原因です。エラー結果画面の STATUS 列に INTERNAL_SERVER_ERROR と表示されます。

解決策

後で再試行してください。

原因

既存のユーザーを変更せずに再度アップロードした場合、エラー結果画面の STATUS 欄に「ユーザーは既に追加されています」と表示されます。

ユーザーは既に追加されています

解決策

既存のユーザーを再度アップロードしないでください。既存のユーザーの詳細を含む行を削除します。

原因

このエラーは、Azure Sync または Google Sync の関連ディレクトリで発生します。ユーザーは ID プロバイダー側で管理されます。

解決策

ID プロバイダーポータル上で同期データを編集および管理し、同期を介してその変更を伝搬することをお勧めします。絶対に必要な場合を除き、Admin Console でデータを手動で変更しないでください。

原因

必要な列のヘッダー(例:Email など)は存在するが、対応する行の値がない場合は、結果画面の STATUS 列にデータの解析エラーメッセージが表示されます。

Error parsing

解決策

各行に対応する値を入力してください。

原因

このエラーは、Enterprise ID または Federated ID ユーザーであって、ドメインが以下の条件を満たしていない場合に発生します。

  • Domain 列に有効なドメイン名が指定されている
  • 有効なドメイン名を含むメール ID
  • 有効なドメイン名を含むユーザー名

ドメインが見つかりませんでした」メッセージは、結果画面の STATUS 列に表示されます。

注意:

このエラーは、無効なドメイン名を使用した場合に発生します。そのドメインが組織によって主張されていない、または信頼されていないことを意味します。

解決策

次の手順を実行します。

  • Domain 列に有効なドメイン名を入力します。
  • ID タイプに対応する、有効なメール ID を入力します。
  • ID タイプに対応する、有効なユーザー名を入力します。

原因

このエラーは、ユーザーの追加先のドメインを組織が所有していない場合に発生します。

解決策

ユーザーをドメインに追加するには、次のいずれかの操作を行います。

原因

このエラーは、Enterprise ID または Federated ID のユーザーであって、Country Code Heading、データ値、またはその両方が欠けている場合に、エラーが発生します。

結果画面の STATUS 列に「国コードには 2 文字の ISO-3166 値を指定してください」というメッセージが表示されます。

国コードエラー

解決策

Country Code 列のヘッダーと、それに対応する有効な行の値が入力されていることを確認してください。

原因

このエラーは、組織がエンタープライズストレージモデルに更新されていて、CSV に ID タイプとして Adobe ID が入力されている場合に発生します。

解決策

ID のタイプは「Enterprise ID」または「Federated ID」のいずれかを選択する必要があります。

原因

このエラーは通常、CSV ファイル内のユーザー名が組織の Admin Console 内のどのユーザーにも対応していない場合に発生します。これは、Adobe Admin Console での既存の利用可能なユーザーの操作中にトリガーされます。

ユーザーが組織に属していない

解決策

管理者は、CSV フィールドに指定されたユーザー名の値が、Adobe Admin Console で利用可能なユーザー情報内に既に存在するかどうかを検証する必要があります。

原因

このエラーは、ユーザー ID の切り替え中にのみ発生します。CSV ファイルでは、指定されたユーザー名は一致しますが、メールは Admin Console のディレクトリ内のメールと一致しません。

メールは一致する必要があります

解決策

メールが Admin Console のディレクトリに定義されたドメインと一致することを確認します。

ユーザーの一括アップロードでなお問題が解決できない場合は、システム管理者またはサポート管理者であれば、ケースを作成するか、チャットを開始するか、既存のケースを Admin Console の「サポート」タブで管理してください。

詳しくは、サポートケースの作成」を参照してください。

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