Extract adobe_prtk from downloaded zip on the host machine for Windows.
Issue
When users try to launch a product, the following screen is displayed because users are unable to activate device licenses on their computers:
Cause
There is no mechanism through the Admin Console or the APTEE (adobe_prtk) tool to unarchive a computer for the same device license, once deactivation has been performed through the Admin Console.
Solution
To remove a computer from the deactivation pool and reactivate it, the activation command needs to be run through the custom adobe_prtk available from this page. Download the adobe_prtk and follow the steps for the OS of the host computer:
Windows OS
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Copy the prov.xml for device license to the same folder as the extracted adobe_prtk tool.
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Open the Windows command prompt with the Run as Administrator option.
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In command prompt, Navigate to the location of the extracted adobe_prtk folder.
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Type command the following command and Enter:
adobe_prtk --tool=GetPackagePools --provfile=prov.xml
MAC OS
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Extract adobe_prtk from downloaded zip on the host machine for MAC OS.
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Copy the prov.xml for device license to the same folder as the extracted adobe_prtk tool.
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Open the terminal and navigate to the extracted adobe_prtk folder.
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Navigate to the location of the extracted adobe_prtk folder in terminal
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Type the following command and press Enter:
sudo ./adobe_prtk --tool=GetPackagePools --provfile=prov.xml
You will be prompted for the administrator password.
The above steps (for Windows and MAC OS) unblock the archived (deactivated) computer. Activation proceeds with the command’s return code as zero.
The files present in the SLCache and SLStore folders should not be removed. This might result in an inconsistent state of licensing information on the host computer.